Error Message when connecting to Exchange calendar

Need help with VueMinder Pro or Ultimate? Ask your questions here.

Error Message when connecting to Exchange calendar

Postby mk53v3n » Thu Nov 03, 2016 12:13 pm

Hi! I just downloaded the trial-version of VueMinder Ultimate because I am looking for a calendar app that allows me to display my private Google calendar and my two workplace Exchange calendars in one place.

Adding my private Google calendar was very easy and works without any problems.

I have two different employers and therefore two different work calendars. Both are Exchange calendars.
The first one is hostet in Office 365, the other one is hosted on a server by my employer.

Adding the Office 365 Exchange calendar works fine, but I am unable to add my second Exchange calendar.

I go to "File -> Add calendar -> Add Exchange calendar...", uncheck the box "Use default login credentials" in the corresponding dialog and insert the exact same data that I enter in my other mail and calendar clients, i.e. my mail-address, username, password and domain.
(So until now, the exact same steps I performed when adding my first Office 365 Exchange calendar)

Then, after clicking on "Connect", in the following window beneath the drop-box titled "Mailbox name", I click on the entry "My Calendars".
When I do so, I receive the following error message (unfortunately the first part of the error message is unreadable - see attachment to this thread):

"Error:
<Cryptic stuff> The remote server returned an error: (401) "

I have tried it several times now but I just can't get it to work.
Any help would really be appreciated.

Thanks and best regards,
Markus
Attachments
VueError.PNG
VueError.PNG (5.35 KiB) Viewed 8491 times
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am

Re: Error Message when connecting to Exchange calendar

Postby mk53v3n » Thu Nov 03, 2016 5:27 pm

Very, very strange: After waiting a couple of hours now and rebooting the PC, I just tried again to add the calendar to VueMinder (just wanted to give it another try).

I used the exact same credentials as before, and, what can I say, no error message anymore.
The calendar was added and appears in the list of calendars now.

However, VueMinder says that the added calendar contains 0 events (which is of course not correct).

I tried to sync it manually several times now, but nothing happens. No error message is displayed either.

Really hope you guys can help me with this issue.

Thanks in advance and best regards,
Markus
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am

Re: Error Message when connecting to Exchange calendar

Postby VueSoft » Thu Nov 03, 2016 10:15 pm

Hi Markus, welcome to the forums.

I go to "File -> Add calendar -> Add Exchange calendar...", uncheck the box "Use default login credentials" in the corresponding dialog and insert the exact same data that I enter in my other mail and calendar clients, i.e. my mail-address, username, password and domain.

Usually, the domain name can be left blank. I'm not sure why you were able to successfully connect later, but it's possible the problem you're having with events not appearing could be related. Try re-adding the calendar, but leave the domain name blank when connecting.

If that doesn't fix it, do you know which version of Exchange Server your employer is using? VueMinder will only work with Exchange Server 2010 or later. Also, Exchange Web Services (EWS) and Autodiscover need to be enabled on the server. It's possible these have been disabled, or your account doesn't have the necessary permissions for accessing the server through EWS.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA
User avatar
VueSoft
Dan Chartrand
 
Posts: 3575
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA

Re: Error Message when connecting to Exchange calendar

Postby mk53v3n » Fri Nov 04, 2016 4:37 am

Hi Dan,

thank you very much for the fast reply.

I just edited this message, because I tried what you suggested about 30 minutes ealier and it didn't seem to work at first.

However, I just kept VueMinder open and did not remove the newly added calendar this time.
I just came back to the computer and what do I see - a little message "Synchronizing with Microsoft Exchange" in the left bottom corner of the window and slowly all my appointments are added to the calendar one by one.

I begin to think that it would already have worked yesterday, if I just had waited long enough.

What confused me was the fact, that it only took about 10 seconds for my other two calendars to completely show up in VueMinder.
My third calendar now took roughly 30 minutes, before it even began synchronizing.

However, it seems that there are still problems in syncing events for my newly added Exchange calendar (the other two calendars which I added yesterday work fine).

VueMinder -> Exchange
When I add a new appointment in VueMinder, it takes a couple of minutes to appear in my other calendar apps. If I close VueMinder shortly after I have added the new appointment (without waiting for it to appear on the other calendars), the appointment seems to be not synchronized at all. Are not all calendars automatically synchronized once when VueMinder is closed? Do I have to trigger a manual sync before closing to make sure that all events are properly synchronized?

Exchange -> VueMinder
This direction does not seem to work at all or I just have to wait longer, like I did for the initial synchroniziation described above.
I added a new appointment in Outlook around 15 minutes ago and it still is not displayed in VueMinder (although I triggered the manual sync several times now and even restarted my computer and VueMinder). However, the appointment is already visible in all my other calendar / mail apps.

It seems that there are still some synchronization issues for this Exchange account?
However, the other two accounts work without any problems.

Best regards,
Markus
Last edited by mk53v3n on Fri Nov 04, 2016 8:30 am, edited 1 time in total.
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am

Re: Error Message when connecting to Exchange calendar

Postby mk53v3n » Fri Nov 04, 2016 8:29 am

Short addition:

Even after waiting for a couple of hours now, no appointments that I created in my Outlook calendar (using Outlook 2016) after I added the calendar to VueMinder does appear in VueMinder. I created several new appointments now and they are just not visible in the VueMinder calendar.

However, those events almost instantly appear in any other calendar tools I use, e.g. on my smartphone. So, something seems to be wrong here with the sync in VueMinder :(

Probably it's worth to mention that - in most other mail / calendar tools - I additionally have to specify the server address and the domain for my exchange account (which I did not in VueMinder). Could this be the reason for the sync issues I'm experiencing here?
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am

Re: Error Message when connecting to Exchange calendar

Postby VueSoft » Fri Nov 04, 2016 11:09 pm

Hi Markus, thank you for the information. VueMinder syncs using Exchange Web Services (EWS), which might be a different syncing mechanism than used by your other apps. It's possible your Exchange Server isn't properly configured for EWS, or your mailbox account is lacking the necessary permissions.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA
User avatar
VueSoft
Dan Chartrand
 
Posts: 3575
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA

Re: Error Message when connecting to Exchange calendar

Postby mk53v3n » Wed Nov 09, 2016 3:32 am

Hi Dan, I spoke to our admin about the issue again. He insists that the Exchange server is properly configured, as no one else in the company is encountering any issues (everyone uses Outlook).

However, I just tested the connectivity with the Microsoft Remote Connectivity Analyzer (https://testconnectivity.microsoft.com/) and it returned the following error message:

"Exchange Web Services synchronization, notification, availability, and Automatic Replies.
Not all tests of Exchange Web Services tasks completed.

Additional Details

Test Steps

The Microsoft Connectivity Analyzer is attempting to test Autodiscover for xxx@xxx.de.
Autodiscover was tested successfully.

Creating a temporary folder to perform synchronization tests.
Failed to create temporary folder for performing tests.

Additional Details

Exception details:
Message: The request failed. The remote server returned an error: (501) Not Implemented.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)
at Microsoft.Exchange.WebServices.Data.ExchangeService.InternalBindToFolders(IEnumerable`1 folderIds, PropertySet propertySet, ServiceErrorHandling errorHandling)
at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
at Microsoft.Exchange.Tools.ExRca.Tests.GetOrCreateSyncFolderTest.PerformTestReally()
Exception details:
Message: The remote server returned an error: (501) Not implemented.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.WebServices.Data.EwsHttpWebRequest.Microsoft.Exchange.WebServices.Data.IEwsHttpWebRequest.GetResponse()
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
Elapsed Time: 11247 ms."


Are you familiar with this error? Could this be the reason for the syncing issues I am experiencing in VueMinder?
Is there any logfile or anything similar in VueMinder where I could look up the detailed reason why the sync fails?
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am

Re: Error Message when connecting to Exchange calendar

Postby VueSoft » Wed Nov 09, 2016 11:06 pm

Hi Markus, thank you for the information. Do you know if your Exchange Server is load balanced? There's a known issue if using KEMP LB which will result in the error you're seeing. It could also cause an incorrect autodiscover URL for EWS, which would explain the problems VueMinder is encountering when attempting to sync with your server.

Here are some links to pages that provide additional information:
https://social.technet.microsoft.com/Fo ... gesvradmin
http://c7solutions.com/2014/06/exchange ... -501-error

I'm familiar with writing code that uses the EWS API to sync data - but not so much on the actual administration of Exchange Server. Hopefully your admin will be able to assist.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA
User avatar
VueSoft
Dan Chartrand
 
Posts: 3575
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA

Re: Error Message when connecting to Exchange calendar

Postby mk53v3n » Thu Nov 10, 2016 4:34 am

Hi Dan, thank you very much for the links!

I forwarded these to our admin and he confirmed that we are indeed using the load balancing techniques you mentioned.
However, he says that there are multiple other services beside Exchange in our company that use these load balancers. Therefore he can't change anything because it is a global setting that would affect other services as well.

That's so very disappointing. I really liked what I saw of VueMinder thus far and really had hoped that I found the perfect solution for my needs.
But since its not "compatible" with our company environment, I'm afraid I will have to keep on looking for alternatives.

However, thanks again very much for the friendly support. I really appreciate your time and effort to help me get the software to work!
mk53v3n
 
Posts: 6
Joined: Thu Nov 03, 2016 11:54 am


Return to Technical Support

cron