Page 1 of 1

Prob syncing w/Google - Now have multiple copies of events

PostPosted: Tue Nov 07, 2017 2:24 am
by remo_253
Vueminder stopped syncing with Google calendar. I had added an event to Google and Vueminder wasn't picking it up, even after manually telling it to sync multiple times.

So I disabled syncing in VM, re-enabled it, and then it started syncing. However, it duplicated everything that was already there, and still didn't pick up the new event. I deleted some of the dups in Google and that caused the only copy in VM to disappear.

I restored a backup of VM and tried again, which resulted in it re-adding the dups I'd deleted from Google, and for those I hadn't touched in Google I now have three copies.

Shouldn't VM see an event already exists and not duplicate it?? How do I clear up this mess? If I delete any of the dups from Google then the only copy in VM gets deleted.

Windows 7, VM Pro 2017.04

Re: Prob syncing w/Google - Now have multiple copies of even

PostPosted: Wed Nov 08, 2017 1:02 am
by VueSoft
Hi remo, if you disabled and re-enabled syncing with Google Calendar via the Sync tab on the Calendar Properties window in VueMinder, this will result in a new calendar being added to your Google account. Basically, when a local calendar in VueMinder is configured to sync with Google, VueMinder won't first check your Google account to see if there are any other calendars that might be a match. It will just upload as a new calendar to your account. If you did this multiple times, that would explain why you're seeing duplicates.

Please try these steps:
1. On the Google Calendar webpage, click the drop-down arrow next to "My calendars" and select "Settings".
2. You probably have multiple calendars of the same name, which were (at some point) uploaded by VueMinder. Click the "Unsubscribe" link for each of the duplicate calendars. This will remove the calendar (and duplicate events) from your account.
3. In VueMinder, open the Calendar Properties of the calendar you'd like to sync with Google Calendar.
4. On the Sync tab, uncheck "Sync with Google Calendar" and click OK.
5. Re-open the Calendar Properties.
6. On the Sync tab, check "Sync with Google Calendar". As described above, the calendar will upload to your Google account as a new calendar. If you deleted all the previous duplicate calendars, you should NOT see any duplicates after the calendar uploads.

Re: Prob syncing w/Google - Now have multiple copies of even

PostPosted: Wed Nov 08, 2017 6:53 pm
by remo_253
Dan,

Thank you for the reply. I was able to get everything straightened out. I still have an issue with items created on my phone not syncing but I'll do some research on that, I think it's a google issue more than VM.

Re: Prob syncing w/Google - Now have multiple copies of even

PostPosted: Wed Nov 08, 2017 7:03 pm
by VueSoft
Are you using the official Google Calendar app on your phone, or something else? Is the app syncing with the same Google account as VueMinder? Also, make sure when you create an event, it's associated with the same calendar that VueMinder has been configured to sync. I hope that helps.